How to create ER diagram for existing database with Toad for SQL Server

This article will show you how to generate Entity-Relationship Diagram (ERD) in Toad for SQL Server.

  1. Click Diagram icon or choose from menu Tools -> Diagram.

  1. You can build a diagram by drag and drop tables/views from object explorer to database diagram workspace.
    Another way is select multiple tables you want to have in a diagram, then right click in object explorer -> Send To -> Database Diagram (this way you don’t need to open Diagram from menu - you can do it in any object explorer).
  • arrange - automatically rearrange diagram to be more readable
  • resize - automatically adjust table size in diagram
  • zoom - adjust workspace zoom
  • reference depth - when you add a new table, all references and all referencing tables are added too, if depth is set to 1 (if set to 2, related tables of related tables are added etc.)
  • object details - open details of selected object
  • all objects - adds to a diagram all database objects and references from other databases
  1. Next click Publish option (require Toad Intelligence Central Connection)
  2. To save the diagram as image click File -> Print Preview option. In print preview window click File -> Export Document ... -> Image File or click on Export Document icon

Sample ERD:

Open in new window

0
There are no comments. Click here to write the first comment.