How to generate database documentation with Aqua Data Studio

Bart Gawrych - Dataedo Team Bart Gawrych 2019-05-15 2019-06-29

Table of Contents:


    This tutorial will show you how to generate database documentation using Aqua Data Studio.

    First, you will need an ER diagram for documentation - there are two ways to do it:

    Option 1: Generate option

    Now in the Servers Panel find database/schema which documentation you want (if you want to have all schemas in the documentation you can change it in next step). Right-click on any element which belongs to that schema/database and select Tools -> ER Diagram Generator from the context menu.

    ER Diagram Generator in servers panel context menu

    In the new window, you can specify what objects your documentation should contain. Make sure to check the Include Comments option to have your comments in the documentation. Here you can select to generate documentation for all schemas by selecting in Schema field < All Schemas > option.

    ER Diagram Gererator options

    Click Next button to generate ER Diagram.

    Click here to generate documentation

    Option 2: ER Modeler

    You can also create a new ER Model by selecting from toolbar ER Modeler -> New or File -> New -> ER Model.

    Creating a new ER Model in Aqua Data Studio

    In the new window, you must select your database type and its version. Click OK.

    *Database types

    Next new window will appear with blank workspace, where you can create your own ERD. But this is not our goal. To generate documentation select Tools -> Import Database from toolbar.

    Importing database in ER Modeler

    In the pop-up window select database instance which documentation you want.

    Choosing Server

    In the next step, you can select database, schema, object types and objects documentation should include. Make sure to check Include Comments.

    Import options in ER Modeler

    Click the Next button to start generation process. You should then see the generated ER diagram in your workspace, but without a name, and one blank ER diagram sheet.

    ER Modeler after import

    Delete Untitled 1 sheet by right click on it and selecting Delete Sheet.

    Removing sheet for workspace

    Rename Untitled 2 sheet to appropriate by right click and selecting Rename Sheet.

    Renaming sheet in ER Modeler

    Generating Report from ER Diagram

    Now we are able to generate HTML documentation. To do this, select Tools -> Generate HTML Report from toolbar.

    Generate HTML Report option in ER Modeler

    In the new window select path to save your documentation. Aqua Data Studio generates HTML files and compresses it to zip file, so you need to decompress it to continue. To see your documentation, open the index.html file.

    Sample generated documentation

    0
    There are no comments. Click here to write the first comment.